Daub Logo
Products Downloads Buy Company Community my Daubnet
Login

Community

Discussions, answers and collaboration - Questions - get in touch with the developers and other users. Join today!
Create a free Daubnet Account

Ages! Forum Diagramme, Stammbäume und Grafiken Unterstrich _ wird in Diagrammen und Listen nicht ausgegeben  


 

Unterstrich _ wird in Diagrammen und Listen nicht ausgegeben

 
 
 
Post8. Dec 2011, 01:19
Ich glaube ich bin schon einmal über diesen Bug? gestolpert. Nun stört er mich aber wieder ziemlich: ich versuche E-Mailadressen über das Adressfeld auszugeben (bisher einzige Möglichkeit). Z.B. "freund_name@provider.com".
Leider wird bei der Ausgabe der Unterstrich "_" nicht ausgegeben, bzw. scheinbar "verschluckt". Bei E-Mail-Adressen ist dies natürlich fatal, denn die Adresse "freundname@provider.com" funktioniert nicht. Ich habe nun extra versucht auch andere Eingabefelder (Beruf, Ort) mit Unterstrich "_" zu befüllen und auch diese Felder werden sowohl bei Diagrammen als auch bei Listen ohne "_" ausgegeben.
Kann bitte jemand den Fehler nachstellen/bestätigen und der Autor ev. Bescheid geben, ob es einen Workarround zur korrekten Ausgabe gibt?

Ages! 2.0 - Gutes Forschen und viel Erfolg! Prioritäten: Standards (GEDCOM Export/Import), Datensicherheit, Quellen und Publizierbarkeit. Über 15.000 Personen. Win7x32 3 GB RAM. Meine Ages Wunschliste - CRα
 
 
 

Re: Unterstrich _ wird in Diagrammen und Listen nicht ausgeg

Post8. Dec 2011, 02:59
ChristianR wrote:Ich glaube ich bin schon einmal über diesen Bug? gestolpert. Nun stört er mich aber wieder ziemlich: ich versuche E-Mailadressen über das Adressfeld auszugeben (bisher einzige Möglichkeit). Z.B. "freund_name@provider.com".
Leider wird bei der Ausgabe der Unterstrich "_" nicht ausgegeben, bzw. scheinbar "verschluckt". Bei E-Mail-Adressen ist dies natürlich fatal, denn die Adresse "freundname@provider.com" funktioniert nicht. Ich habe nun extra versucht auch andere Eingabefelder (Beruf, Ort) mit Unterstrich "_" zu befüllen und auch diese Felder werden sowohl bei Diagrammen als auch bei Listen ohne "_" ausgegeben.
Kann bitte jemand den Fehler nachstellen/bestätigen und der Autor ev. Bescheid geben, ob es einen Workarround zur korrekten Ausgabe gibt?

Auch bei mir wird der Unterstrich nicht ausgegeben, obwohl er in einem Rechenfeld (RESI.ADDRESS) gefunden wird.
Ich vermute, dass dies mit der Kennzeichnung von Rufnamen durch Unterstrich zusammenhängt; hier werden die Unterstriche ja auch nicht ausgegeben, führen aber zu falschen Sortierfolgen.
Auch ein einzelner Unterstrich innerhalb eines Rechenfeldes wird in einer Liste nicht dargestellt.
Und doch gibt es eine Krücke, um einen Unterstrich in der Ausgabe darzustellen:
Code: Select all
=IF(FIND("_",RESI.ADDRESS),LEFT(RESI.ADDRESS,FIND("_",RESI.ADDRESS)-1),RESI.ADDRESS)
=IF(FIND("_",RESI.ADDRESS),RIGHT(RESI.ADDRESS,LEN(RESI.ADDRESS)-FIND("_",RESI.ADDRESS)),,)
wobei für das zweite Rechenfeld ein Unterstrich als Präfix-Zeichen angegeben wird.

Ahnenforschung für die Familie und für das, was mich sonst noch interessiert
Ich suche Informationen über Angehörige des 3.Brandenburgischen Jägerbataillons in Lübben/Spreewald (zwischen 1860 und 1870)
 
 
 

Re: Unterstrich _ wird in Diagrammen und Listen nicht ausgeg

Post8. Dec 2011, 16:38
Derzeit ist es nicht möglich, Unterstriche auf regulärem Wege auszugeben. Das war vor einer ganzen Weile hier schon einmal Thema.
Site Admin
jcd
 
 
 

Re: Unterstrich _ wird in Diagrammen und Listen nicht ausgeg

Post9. Dec 2011, 13:04
Danke für die Antworten. Ich habe im Forum vor dem Erstellen hier nach "Unterstrich" gesucht. Leider wurde der Thread "Personenstammblatt: keine Unterstriche?" nicht gefunden. Mit "Unterstrich*" funktioniert es dann. Wenn möglich, wäre es angenehm wenn eine erweiterte Wortsuche in der Forensoftware voreingestellt würde.
Dieter Brühne wrote:Und doch gibt es eine Krücke, um einen Unterstrich in der Ausgabe darzustellen:
Code: Select all
=IF(FIND("_",RESI.ADDRESS),LEFT(RESI.ADDRESS,FIND("_",RESI.ADDRESS)-1),RESI.ADDRESS)
=IF(FIND("_",RESI.ADDRESS),RIGHT(RESI.ADDRESS,LEN(RESI.ADDRESS)-FIND("_",RESI.ADDRESS)),,)
wobei für das zweite Rechenfeld ein Unterstrich als Präfix-Zeichen angegeben wird.

Danke für den Hinweis auf dieses nützliche Konstrukt bis zur Behebung des Bugs. Soweit ich es interpretiere: wenn aber zwei (oder mehr) Unterstriche im Feld enthalten sind, dann fehlt der Text zwischen dem ersten und letzten Unterstrich?
Last edited by ChristianR on 9. Dec 2011, 13:57, edited 2 times in total.

Ages! 2.0 - Gutes Forschen und viel Erfolg! Prioritäten: Standards (GEDCOM Export/Import), Datensicherheit, Quellen und Publizierbarkeit. Über 15.000 Personen. Win7x32 3 GB RAM. Meine Ages Wunschliste - CRα
 
 
 

Re: Unterstrich _ wird in Diagrammen und Listen nicht ausgeg

Post9. Dec 2011, 13:32
ChristianR wrote:Danke für dieses nützliche Konstrukt bis zur Behebung des Bugs. Soweit ich es interpretiere: wenn aber zwei (oder mehr) Unterstriche im Feld enthalten sind, dann fehlt der Text zwischen dem ersten und letzten Unterstrich?
Nein, aber der Text zwischen dem ersten und zweiten Unterstrich wird wie bei Rufnamen unterstrichen dargestellt.
Bei Bedarf muss also die Aufbereitung des zweiten Rechenfeldes noch modifiziert werden.
So wird mit folgendem Rechenfeld die Unterstreichung des zweiten Teils verhindert, jetzt muss dieser zweite Teil nur noch aufgeteilt werden.
Code: Select all
=IF(FIND("_",RESI.ADDRESS),RIGHT(RESI.ADDRESS,LEN(RESI.ADDRESS)-FIND("_",RESI.ADDRESS)-1),,)

Ahnenforschung für die Familie und für das, was mich sonst noch interessiert
Ich suche Informationen über Angehörige des 3.Brandenburgischen Jägerbataillons in Lübben/Spreewald (zwischen 1860 und 1870)
 
 
 

Re: Unterstrich _ wird in Diagrammen und Listen nicht ausgeg

Post9. Dec 2011, 14:00
Dieter Brühne wrote:Nein, aber der Text zwischen dem ersten und zweiten Unterstrich wird wie bei Rufnamen unterstrichen dargestellt.
Bei Bedarf muss also die Aufbereitung des zweiten Rechenfeldes noch modifiziert werden.
So wird mit folgendem Rechenfeld die Unterstreichung des zweiten Teils verhindert, jetzt muss dieser zweite Teil nur noch aufgeteilt werden.
Code: Select all
=IF(FIND("_",RESI.ADDRESS),RIGHT(RESI.ADDRESS,LEN(RESI.ADDRESS)-FIND("_",RESI.ADDRESS)-1),,)

Danke für die Erklärung. Es gibt bei mir ein weiteres unschönes Merkmal: Zwischen der Ausgabe der beiden Rechenfelder wird bei mir ein Leerzeichen eingefügt, sodass es dann so aussieht: "freund _name@provider.com". Ich glaube nicht, dass sich das vermeiden lässt oder?
Da lasse ich mir ev. lieber einen Hinweis ausgeben, wenn ein Unterstrich im Feld vorhanden ist:
Code: Select all
=IF(FIND("_",RESI.ADDRESS),RESI.ADDRESS,"")
=IF(FIND("_",RESI.ADDRESS),"",RESI.ADDRESS)

Das erstere Feld lasse ich in einer anderen Farbe ausgeben, das zweitere normal.

Ages! 2.0 - Gutes Forschen und viel Erfolg! Prioritäten: Standards (GEDCOM Export/Import), Datensicherheit, Quellen und Publizierbarkeit. Über 15.000 Personen. Win7x32 3 GB RAM. Meine Ages Wunschliste - CRα
 
 
 

Re: Unterstrich _ wird in Diagrammen und Listen nicht ausgeg

Post9. Dec 2011, 15:28
Ich habe es nur kurz angetestet, aber es sieht so aus, als ob ein Voranstellen zweier Unterstriche das Problem umgeht:

Code: Select all
="__"&RESI.ADDRESS
Site Admin
jcd
 
 
 

Re: Unterstrich _ wird in Diagrammen und Listen nicht ausgeg

Post9. Dec 2011, 18:29
jcd wrote:Ich habe es nur kurz angetestet, aber es sieht so aus, als ob ein Voranstellen zweier Unterstriche das Problem umgeht:

Code: Select all
="__"&RESI.ADDRESS

Funktioniert aber nur, wenn die Mail-Adresse am Anfang einer evtl. mehrzeiligen Adresse steht. Im anderen Fall erfolgt die Darstellung ggf. durch Unterstreichen.

Ahnenforschung für die Familie und für das, was mich sonst noch interessiert
Ich suche Informationen über Angehörige des 3.Brandenburgischen Jägerbataillons in Lübben/Spreewald (zwischen 1860 und 1870)
 
 
 

Re: Unterstrich _ wird in Diagrammen und Listen nicht ausgeg

Post14. Dec 2011, 17:24
Sofern die E-Mail Adresse nur maximal einen Unterstrich enthält, sollte folgende Formel abhelfen:
Code: Select all
=SUBSTITUTE(RESI.ADDRESS,"_","___")
Site Admin
jcd
 
 
 

Re: Unterstrich _ wird in Diagrammen und Listen nicht ausgeg

Post15. Dec 2011, 14:03
jcd wrote:Sofern die E-Mail Adresse nur maximal einen Unterstrich enthält, sollte folgende Formel abhelfen:
Code: Select all
=SUBSTITUTE(RESI.ADDRESS,"_","___")

Danke. Bis zur Behebung des Bugs (bzw. Möglichkeit der direkten Ausgabe von E-Mails etc.) werde ich nun wohl folgenden Code einsetzen:
=IF(FIND("_",RESI.ADDRESS),,RESI.ADDRESS,)
=IF(FIND("_",RESI.ADDRESS),SUBSTITUTE(RESI.ADDRESS,"_","___"),,)
Zweiteres in einer anderen Farbe ausgegeben, damit ich es kontrollieren kann.

Ages! 2.0 - Gutes Forschen und viel Erfolg! Prioritäten: Standards (GEDCOM Export/Import), Datensicherheit, Quellen und Publizierbarkeit. Über 15.000 Personen. Win7x32 3 GB RAM. Meine Ages Wunschliste - CRα