Daub Logo
Produkte Downloads Kaufen Company Community mein Daubnet
Anmelden

Community

Diskussionen, Fragen und Zusammenarbeit - hier ist der richtige Platz für den Austausch mit den Entwicklern und mit anderen Usern. Machen Sie mit!
Kostenloses Daubnet-Konto erstellen

Ages! Forum Rechenfelder Probleme mit "Hatschek"  


 

Probleme mit "Hatschek"

 
 
 
Beitrag29. Mai 2015, 20:10
Hallo Mitforscher!

Ich nutze nun schon seit 1 1/2 Jahren Ages. Habe mir für meine Vorlagen auch etliche Formeln erstellt, diese funktionieren großteils auch.

Unter anderen habe ich eine Formel die mir im Diagramm den Mädchennamen und den Nachnamen nach einer Heirat angibt (bei mehreren Ehen auch alle Namen -> bis zu 3 Stk.).

Diese sieht wie folgt aus:
Code: Alles auswählen
IF(
  MORENAMES[3].TYPE = "verh.",
            MORENAMES[3].LASTNAME & ", "
          &
            MORENAMES[2].LASTNAME
        &
          ", "             
      &
        MORENAMES[1].LASTNAME
    &
      " geb. "
  &
    LASTNAME,
  IF(
    MORENAMES[2].TYPE = "verh.",
          MORENAMES[2].LASTNAME & ", "
        &
          MORENAMES[1].LASTNAME
      &
        " geb. "
    &
      LASTNAME,
    IF(
      MORENAMES[1].TYPE = "verh.",
        MORENAMES[1].LASTNAME & " geb. "
      &
        LASTNAME,
      LASTNAME
    )
  )
)


Die Ausgabe wäre dann z.B.: "Mustermann geb. Huber".


Funktioniert auch alles super, allerdings wenn ich nun das Diagramm als PDF exportiere, wird das Hatschek über den nächsten Buchstaben im Namen gestellt (also 2 Buchstaben an derselben Stelle).

Sieht natürlich nicht besonders schön aus, habe auch schon einen Workaround, ich erstelle einfach im Namen nach dem Hatschek ein Leerzeichen, damit ist natürlich die Datenbank auch dahin...


Kann mir hier irgendjemand weiterhelfen? Bzw. hatte wer von euch auch schon mal dieses Problem??


PS: Ages Version 2.00, auch mit Ages Version 2.04 keine Besserung
Drucken über PDF Drucktools funktioniert, nur leider nicht auf eine Seite da die größte A0 ist.



Danke für Eure Hilfe!
 
 
 

Re: Probleme mit "Hatschek"

Beitrag12. Jul 2015, 08:46
Kann mir den hier keiner weiterhelfen??

Wird das evt. in einer neuen Version behoben??
 
 
 

Re: Probleme mit "Hatschek"

Beitrag12. Jul 2015, 14:21
Hallo!

Leider kann ich Dir da auch nicht helfen. Ein Problem könnte auch der verwendetet PDF-Reader sein. Hast Du schon mal das Forum diesbezüglich durchsucht.

Auf die Schnelle:
viewtopic.php?f=26&t=1090&p=4755&hilit=pdf+ausdrucken#p4755

Gruß
Thomas
 
 
 

Re: Probleme mit "Hatschek"

Beitrag12. Jul 2015, 14:24
Vielleicht auch das betreffend der PDF-Größe:
viewtopic.php?f=26&t=25&p=553&hilit=pdf+ausdrucken#p553
 
 
 

Re: Probleme mit "Hatschek"

Beitrag5. Aug 2015, 02:53
Ich habe immer wieder zwei Probleme mit den Schriften, derart dass Texte übereinander oder gar nicht geschrieben werden. Das liegt wohl am verwendeten Font und eventuell an der Übernahme von Layouts von Ages 1.4.
Ich habe mal mit einem komplett neuen Layout angefangen und so nach und nach die Funktionen wieder eingebaut, bis ich heraus hatte, dass der "dagger" nicht in der letzten Zeile stehen sollte.
Bei den Leerzeichen kann man versuchen mit der Verkettung von Strings herumzuspielen, anstatt diese einzeln abzusetzen, aber ein Erfolgsrezept habe ich auch noch nicht.
CJG
 
 
 

Re: Probleme mit "Hatschek"

Beitrag5. Aug 2015, 07:56
Danke für die Antwort!

Ja auf diese Idee hätte ich selbst auch kommen können...

Mit der Schriftart "Times New Roman" funktioniert es =)


Vielen Dank nochmal.